Back to overview
Downtime

Activity page is unavailable

Dec 02 at 03:58am HST
Affected services
efficiently-hr.vercel.app

Resolved
Dec 02 at 04:00am HST

The problem has been resolved, we have implemented a fix and we're monitoring the results.

Created
Dec 02 at 03:58am HST

Activity is currently loading permanently and is unavailable, our team has identified the issue and they're working on resolving it.